Download Precompiled OSPRay Binary Packages

Prerequisites

Your CPU must support at least SSE4.1 to run OSPRay. The TGZ/ZIP packages contain most needed 3rd party dependencies, whereas for the (much smaller) RPM/installer packages you need to have installed

We recommend the latest version of both TBB and Embree libraries.

Packages

For Linux we provide OSPRay precompiled for 64 bit as RPMs or as TGZ file.

ospray-1.2.1.x86_64.rpm.tar.gz
ospray-1.2.1.x86_64.linux.tar.gz

For Mac OS X we provide OSPRay as an installer and as a TGZ file:

ospray-1.2.1.x86_64.dmg
ospray-1.2.1.x86_64.macosx.tar.gz

For Windows we provide an installer for precompiled 64 bit OSPRay binaries as well as ZIP files:

ospray-1.2.1.exe
ospray-1.2.1.windows.zip

The source code of the latest OSPRay version can be downloaded here:

ospray-1.2.1.zip
ospray-1.2.1.tar.gz

You can also access old OSPRay releases.

Building OSPRay from Source

The latest OSPRay sources are always available at the OSPRay GitHub repository. The default master branch should always point to the latest tested bugfix release.

Prerequisites

OSPRay currently supports Linux, Mac OS X, and Windows. In addition, before you can build OSPRay you need the following prerequisites:

Depending on your Linux distribution you can install these dependencies using yum or apt-get. Some of these packages might already be installed or might have slightly different names.

Type the following to install the dependencies using yum:

sudo yum install cmake.x86_64
sudo yum install tbb.x86_64 tbb-devel.x86_64
sudo yum install freeglut.x86_64 freeglut-devel.x86_64
sudo yum install qt-devel.x86_64

Type the following to install the dependencies using apt-get:

sudo apt-get install cmake-curses-gui
sudo apt-get install libtbb-dev
sudo apt-get install freeglut3-dev
sudo apt-get install libqt4-dev

Under Mac OS X these dependencies can be installed using MacPorts:

sudo port install cmake tbb freeglut qt4

Compiling OSPRay

Assume the above requisites are all fulfilled, building OSPRay through CMake is easy:


  1. For example, if OSPRay is in ~/Projects/ospray, ISPC will also be searched in ~/Projects/ispc-v1.9.1-linux and ~/Projects/ispc-v1.9.0-linux